summaryrefslogtreecommitdiffstats
path: root/src/profiles/IDE/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-29 22:43:34 +0200
committerMichele Calgaro <[email protected]>2020-08-01 17:56:29 +0900
commit96fa25303818e6107b72ba624659004751d45ad1 (patch)
tree89a7233f17e403e6b635d2ce7155d5f77a98d3d8 /src/profiles/IDE/CMakeLists.txt
parent3248c8c2f99f71bb2ca5972828754fdabacd7c90 (diff)
downloadtdevelop-96fa25303818e6107b72ba624659004751d45ad1.tar.gz
tdevelop-96fa25303818e6107b72ba624659004751d45ad1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit fe44776673b28ca94338f23d8e7ac71593fa88ba)
Diffstat (limited to 'src/profiles/IDE/CMakeLists.txt')
-rw-r--r--src/profiles/IDE/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/profiles/IDE/CMakeLists.txt b/src/profiles/IDE/CMakeLists.txt
index e98b3133..a3ceb026 100644
--- a/src/profiles/IDE/CMakeLists.txt
+++ b/src/profiles/IDE/CMakeLists.txt
@@ -13,6 +13,8 @@ add_subdirectory( CompiledLanguageIDE )
add_subdirectory( ScriptingLanguageIDE )
add_subdirectory( DatabaseIDE )
-install( FILES
- profile.config
- DESTINATION ${DATA_INSTALL_DIR}/tdevelop/profiles/IDE )
+tde_create_translated_desktop(
+ SOURCE profile.config
+ DESTINATION ${DATA_INSTALL_DIR}/tdevelop/profiles/IDE
+ PO_DIR tdevelop-desktops
+)