summaryrefslogtreecommitdiffstats
path: root/klinkstatus/src/cfg/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-06-28 15:14:51 +0200
committergregory guy <[email protected]>2021-03-11 15:04:14 +0100
commit4c43d1fbb66a296958ed1d0dbddf3f8ac4466130 (patch)
treee532b01e8168b2f849f8aaa3266a58b088705726 /klinkstatus/src/cfg/Makefile.am
parent10d21d001e92e653cec6b6d1c05983abd00a1195 (diff)
downloadtdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.tar.gz
tdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.zip
Conversion to the cmake building system.
Delete empty files (dummy.cpp, xsldbgconfig.h). Remove hard-coded path for the kmdr-executor executable. Replaced $TQTDIR/doc/html string path for TQTDOCDIR in kommander. Add man pages taken from the Debian packaging. Signed-off-by: gregory guy <[email protected]> Fix linking - kxsldbgcommon-static and kimagemapeditorcommon-static needs to be embedded. Move the linking of xml and readline libraries to the appropriate static libraries. Add build option WITH_QUANTA_CVSSERVICE. Add a test whether the readline can be linked standalone or whether ncurses is needed. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'klinkstatus/src/cfg/Makefile.am')
-rw-r--r--klinkstatus/src/cfg/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/klinkstatus/src/cfg/Makefile.am b/klinkstatus/src/cfg/Makefile.am
index 2e74b2ad..02107718 100644
--- a/klinkstatus/src/cfg/Makefile.am
+++ b/klinkstatus/src/cfg/Makefile.am
@@ -2,5 +2,9 @@ kde_kcfg_DATA = klinkstatus.kcfg
METASOURCES = AUTO
libcfg_la_LDFLAGS = $(all_libraries)
noinst_LTLIBRARIES = libcfg.la
+CLEANFILES = dummy.cpp
libcfg_la_SOURCES = dummy.cpp klsconfig.kcfgc
-AM_CPPFLAGS=$(all_includes) \ No newline at end of file
+AM_CPPFLAGS=$(all_includes)
+
+dummy.cpp:
+ echo > dummy.cpp