summaryrefslogtreecommitdiffstats
path: root/lib/compatibility/tdemdi/qextmdi/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-06-28 15:14:51 +0200
committergregory guy <[email protected]>2021-03-11 15:04:14 +0100
commit4c43d1fbb66a296958ed1d0dbddf3f8ac4466130 (patch)
treee532b01e8168b2f849f8aaa3266a58b088705726 /lib/compatibility/tdemdi/qextmdi/CMakeLists.txt
parent10d21d001e92e653cec6b6d1c05983abd00a1195 (diff)
downloadtdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.tar.gz
tdewebdev-4c43d1fbb66a296958ed1d0dbddf3f8ac4466130.zip
Conversion to the cmake building system.
Delete empty files (dummy.cpp, xsldbgconfig.h). Remove hard-coded path for the kmdr-executor executable. Replaced $TQTDIR/doc/html string path for TQTDOCDIR in kommander. Add man pages taken from the Debian packaging. Signed-off-by: gregory guy <[email protected]> Fix linking - kxsldbgcommon-static and kimagemapeditorcommon-static needs to be embedded. Move the linking of xml and readline libraries to the appropriate static libraries. Add build option WITH_QUANTA_CVSSERVICE. Add a test whether the readline can be linked standalone or whether ncurses is needed. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'lib/compatibility/tdemdi/qextmdi/CMakeLists.txt')
-rw-r--r--lib/compatibility/tdemdi/qextmdi/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/compatibility/tdemdi/qextmdi/CMakeLists.txt b/lib/compatibility/tdemdi/qextmdi/CMakeLists.txt
new file mode 100644
index 00000000..12bb58e5
--- /dev/null
+++ b/lib/compatibility/tdemdi/qextmdi/CMakeLists.txt
@@ -0,0 +1,27 @@
+#add_subdirectory( res )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/compatibility/tdemdi/qextmdi/res
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+##### quantatdemdi (static)
+
+tde_add_library( quantaqextmdi STATIC_PIC AUTOMOC
+
+ SOURCES
+ tdemdichildarea.cpp tdemdichildfrm.cpp
+ tdemdichildfrmcaption.cpp tdemdichildview.cpp
+ tdemdimainfrm.cpp tdemditaskbar.cpp
+ tdemultitabbar.cpp tdemditoolviewaccessor.cpp
+ tdemdidocumentviewtabwidget.cpp tdemdifocuslist.cpp
+ tdemdiguiclient.cpp ktabwidget.cpp
+ ktabbar.cpp kdockwidget.cpp
+ kdockwidget_private.cpp tdemdidockcontainer.cpp
+ LINK
+ tdeparts-shared
+)