summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2016-09-18 20:59:45 +0200
committerSlávek Banko <[email protected]>2016-09-18 21:00:00 +0200
commit1404d26a1e72b9e29f460fe828d42af57d925a99 (patch)
treed67a20b74852662a123da6c6d537d6c84820bad6 /src/CMakeLists.txt
parente92dc6bf694aea0048ea774c3226a135cd61b6ff (diff)
downloadtellico-1404d26a1e72b9e29f460fe828d42af57d925a99.tar.gz
tellico-1404d26a1e72b9e29f460fe828d42af57d925a99.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 3f7006b6807add37a3de957c525600a31424a498)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..342ce63
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,83 @@
+#################################################
+#
+# (C) 2016 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/core
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/core
+ ${LIBXML_INCLUDE_DIRS}
+ ${LIBXSLT_INCLUDE_DIRS}
+ ${EXEMPI_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${POPPLER_LIBRARY_DIRS}
+)
+
+
+##### tellico (executable) ######################
+
+tde_add_executable( tellico AUTOMOC
+ SOURCES
+ borrower.cpp borrowerdialog.cpp
+ borroweritem.cpp calendarhandler.cpp collection.cpp collectionfactory.cpp
+ collectionfieldsdialog.cpp configdialog.cpp controller.cpp detailedentryitem.cpp
+ detailedlistview.cpp document.cpp entry.cpp entryeditdialog.cpp entrygroupitem.cpp
+ entryiconfactory.cpp entryiconview.cpp entryitem.cpp entrymerger.cpp entryupdater.cpp
+ entryview.cpp exportdialog.cpp fetchdialog.cpp fetcherconfigdialog.cpp field.cpp
+ fieldcompletion.cpp filehandler.cpp filter.cpp filterdialog.cpp filteritem.cpp
+ filterview.cpp groupiterator.cpp groupview.cpp image.cpp imagefactory.cpp
+ importdialog.cpp isbnvalidator.cpp iso5426converter.cpp iso6937converter.cpp
+ listviewcomparison.cpp loandialog.cpp loanitem.cpp loanview.cpp main.cpp mainwindow.cpp
+ progressmanager.cpp reportdialog.cpp statusbar.cpp tellico_kernel.cpp tellico_strings.cpp
+ tellico_utils.cpp upcvalidator.cpp viewstack.cpp xmphandler.cpp lccnvalidator.cpp
+ LINK
+ core-static gui-static cite-static fetch-static
+ collections-static newstuff-static translators-static
+ pilotdb-static pilotdb_flatfile-static pilotdb_palm-static
+ rtf2html-static commands-static ${BTPARSE_LIBRARIES} ${WEBCAM_LIBRARIES}
+ tdecore-shared tdefx-shared tdeui-shared tdeio-shared tdehtml-shared
+ tdetexteditor-shared tdeparts-shared tdenewstuff-shared tdeabc-shared
+ ${LIBKCAL_LIBRARY} ${LIBKCDDB_LIBRARY} ${LIBXML_LIBRARIES} ${LIBXSLT_LIBRARIES}
+ ${TAGLIB_LIBRARIES} ${YAZ_LIBRARIES} ${EXEMPI_LIBRARIES} ${POPPLER_LIBRARIES}
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+install(
+ FILES tellicoui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/${CMAKE_PROJECT_NAME}
+)
+install(
+ FILES tellicorc
+ DESTINATION ${CONFIG_INSTALL_DIR}
+)
+
+
+##### directories ###############################
+
+add_subdirectory( core )
+add_subdirectory( gui )
+add_subdirectory( collections )
+add_subdirectory( translators )
+add_subdirectory( fetch )
+add_subdirectory( commands )
+add_subdirectory( cite )
+add_subdirectory( newstuff )
+add_subdirectory( rtf2html )
+tde_conditional_add_subdirectory( BUILD_WEBCAM_SUPPORT barcode )
+add_subdirectory( tests )