summaryrefslogtreecommitdiffstats
path: root/src/rtf2html/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2016-09-18 20:59:45 +0200
committerSlávek Banko <[email protected]>2016-09-18 21:00:00 +0200
commit1404d26a1e72b9e29f460fe828d42af57d925a99 (patch)
treed67a20b74852662a123da6c6d537d6c84820bad6 /src/rtf2html/CMakeLists.txt
parente92dc6bf694aea0048ea774c3226a135cd61b6ff (diff)
downloadtellico-1404d26a1e72b9e29f460fe828d42af57d925a99.tar.gz
tellico-1404d26a1e72b9e29f460fe828d42af57d925a99.zip
Initial cmake conversion
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 3f7006b6807add37a3de957c525600a31424a498)
Diffstat (limited to 'src/rtf2html/CMakeLists.txt')
-rw-r--r--src/rtf2html/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/rtf2html/CMakeLists.txt b/src/rtf2html/CMakeLists.txt
new file mode 100644
index 0000000..400b9a8
--- /dev/null
+++ b/src/rtf2html/CMakeLists.txt
@@ -0,0 +1,29 @@
+#################################################
+#
+# (C) 2016 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### rtf2html (static) #########################
+
+tde_add_library( rtf2html STATIC_PIC AUTOMOC
+ SOURCES fmt_opts.cpp rtf2html.cpp rtf_keyword.cpp rtf_table.cpp
+)