summaryrefslogtreecommitdiffstats
path: root/src/cite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cite/Makefile.am')
-rw-r--r--src/cite/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/cite/Makefile.am b/src/cite/Makefile.am
new file mode 100644
index 0000000..74e7c81
--- /dev/null
+++ b/src/cite/Makefile.am
@@ -0,0 +1,20 @@
+AM_CPPFLAGS = $(all_includes)
+METASOURCES = AUTO
+KDE_OPTIONS = noautodist
+CLEANFILES = *~ *.loT
+noinst_LIBRARIES = libcite.a
+libcite_a_SOURCES = lyxpipe.cpp actionmanager.cpp clipboard.cpp openoffice.cpp
+
+EXTRA_DIST = \
+actionmanager.h actionmanager.cpp \
+lyxpipe.h lyxpipe.cpp \
+actionmanager.h actionmanager.cpp \
+openoffice.h openoffice.cpp \
+clipboard.h clipboard.cpp \
+handler.h
+
+OOO_SUBDIR = ooo
+
+if WITH_OOO
+SUBDIRS = $(OOO_SUBDIR)
+endif