summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-01-14 02:37:59 +0100
committerSlávek Banko <[email protected]>2021-01-15 15:15:43 +0100
commitab700191fa487a238d9cd03c81c9e1ef7124548f (patch)
treec1d1e65ad31314bbe1aa782b2b699a52ca5c0cde /CMakeLists.txt
parentfbb5b1424b098b844b4f744cdeea97ba5279764f (diff)
downloadtork-ab700191fa487a238d9cd03c81c9e1ef7124548f.tar.gz
tork-ab700191fa487a238d9cd03c81c9e1ef7124548f.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 355f00c2bd6f4b2870133d0423420ef8046b7156)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e87a31a..3547cfe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )