summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2013-07-27 17:13:06 +0200
committerSlávek Banko <[email protected]>2013-07-27 18:48:47 +0200
commita915aa74dc1acdd12de97f9d95a848b3b2a17abb (patch)
treef65d926875557195c5f6dd840a517e195eeda20e /configure.in
parent7c2bc4b5ce4fc1a72868aa949e9ec49fbe2e7931 (diff)
downloadtork-a915aa74dc1acdd12de97f9d95a848b3b2a17abb.tar.gz
tork-a915aa74dc1acdd12de97f9d95a848b3b2a17abb.zip
Initial TDE conversion
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index e2293f6..9f9b43c 100644
--- a/configure.in
+++ b/configure.in
@@ -76,13 +76,13 @@ AC_MSG_CHECKING([for KDE version])
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
-kdeversion_save_CXXFLAGS="$CXXFLAGS"
-kdeversion_safe_LIBS="$LIBS"
+tdeversion_save_CXXFLAGS="$CXXFLAGS"
+tdeversion_safe_LIBS="$LIBS"
LIBS="$LIBS $X_EXTRA_LIBS"
CXXFLAGS="$CXXFLAGS $all_includes"
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 2, 90 ) )
#error KDE 3.2
#endif
@@ -93,7 +93,7 @@ AC_COMPILE_IFELSE([
)
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 3, 90 ) )
#error KDE 3.3
#endif
@@ -104,7 +104,7 @@ AC_COMPILE_IFELSE([
)
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 4, 90 ) )
#error KDE 3.4
#endif
@@ -115,7 +115,7 @@ AC_COMPILE_IFELSE([
)
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 5, 2 ) )
#error KDE 3.5.x (x < 2)
#endif
@@ -124,8 +124,8 @@ AC_COMPILE_IFELSE([
,
need_kde351_compat="yes"
)
-CXXFLAGS="$kdeversion_save_CXXFLAGS"
-LIBS="$kdeversion_safe_LIBS"
+CXXFLAGS="$tdeversion_save_CXXFLAGS"
+LIBS="$tdeversion_safe_LIBS"
AC_LANG_RESTORE
if test "$need_kde32_compat" = "yes"; then
@@ -649,13 +649,13 @@ if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
# And if so, warn when they don't match
if test "$kde_libs_prefix" != "$given_prefix"; then
# And if kde doesn't know about the prefix yet
- echo ":"`kde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
+ echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
if test $? -ne 0; then
echo ""
echo "Warning: you chose to install this package in $given_prefix,"
echo "but KDE was found in $kde_libs_prefix."
echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that KDEDIRS contains it, e.g. export KDEDIRS=$given_prefix:$kde_libs_prefix"
+ echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
echo "Then restart KDE."
echo ""
fi