summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2022-01-30 17:07:06 +0100
committerSlávek Banko <[email protected]>2022-02-01 13:00:57 +0100
commitf3392a5eaf4340ec31f8254162f2bd135ed494ec (patch)
tree442b750cf968d717705fc603d33938f6af263d01 /src/CMakeLists.txt
parent32b670138b0fb0c85bf1d55dd6687c6db672b677 (diff)
downloadtork-f3392a5eaf4340ec31f8254162f2bd135ed494ec.tar.gz
tork-f3392a5eaf4340ec31f8254162f2bd135ed494ec.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Added translation of .desktop files. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit f7ce4cdb608b1bbec0180fe3ae059e2cc999b705)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cbab62d..75a73eb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -80,13 +80,17 @@ install(
DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
-tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
+tde_create_translated_desktop(
+ SOURCE ${PROJECT_NAME}.desktop
+ PO_DIR "tork-desktops"
+)
tde_create_translated_desktop(
SOURCE tork_downloadwithfirefox.desktop
tork_downloadwithopera.desktop
tork_downloadwithkonqueror.desktop
DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
+ PO_DIR "tork-desktops"
)
tde_create_translated_desktop(