summaryrefslogtreecommitdiffstats
path: root/src/upnp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/upnp/CMakeLists.txt')
-rw-r--r--src/upnp/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/upnp/CMakeLists.txt b/src/upnp/CMakeLists.txt
new file mode 100644
index 0000000..538f013
--- /dev/null
+++ b/src/upnp/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### ktupnp (static)
+
+tde_add_library( ktupnp STATIC_PIC AUTOMOC
+
+ SOURCES
+ soap.cpp
+ upnpdescriptionparser.cpp
+ upnpmcastsocket.cpp
+ upnprouter.cpp
+ portlist.cpp
+ httprequest.cpp
+ exitoperation.cpp
+ forwardportlist.cpp
+)