summaryrefslogtreecommitdiffstats
path: root/qtinterface/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2011-11-12 22:00:03 -0600
committerTimothy Pearson <[email protected]>2011-11-12 22:00:03 -0600
commit4ef8595d9c407d7bc8f3fa44a2b45425eb8a7b1e (patch)
treea3c015699d177cc0f42c9552881d113332b6b9a0 /qtinterface/CMakeLists.txt
parent0f34dbddf9837ce16427600394b9e9145edd0dc6 (diff)
downloadtqtinterface-4ef8595d9c407d7bc8f3fa44a2b45425eb8a7b1e.tar.gz
tqtinterface-4ef8595d9c407d7bc8f3fa44a2b45425eb8a7b1e.zip
Add native TQt3 support to tqtinterface
Diffstat (limited to 'qtinterface/CMakeLists.txt')
-rw-r--r--qtinterface/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/qtinterface/CMakeLists.txt b/qtinterface/CMakeLists.txt
index 64fbb38..9803386 100644
--- a/qtinterface/CMakeLists.txt
+++ b/qtinterface/CMakeLists.txt
@@ -100,8 +100,13 @@ install(
##### tqt tools #################################
configure_file( tmoc.cmake tmoc @ONLY )
-configure_file( tqt-replace.cmake tqt-replace @ONLY )
-configure_file( tqt-replace-stream.cmake tqt-replace-stream @ONLY )
+if ( NOT HAVE_REAL_TQT )
+ configure_file( tqt-replace.cmake tqt-replace @ONLY )
+ configure_file( tqt-replace-stream.cmake tqt-replace-stream @ONLY )
+else ()
+ configure_file( tqt-replace-tqt3.cmake tqt-replace @ONLY )
+ configure_file( tqt-replace-stream-tqt3.cmake tqt-replace-stream @ONLY )
+endif ()
install( PROGRAMS
moc-tqt uic-tqt mcopidl-tqt dcopidl-tqt dcopidlng-tqt