summaryrefslogtreecommitdiffstats
path: root/qtinterface/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-07-21 21:18:36 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-07-21 21:18:36 +0000
commit5e266f8f85ead4c33f7a9d227a82b0461df7e09a (patch)
tree29ee823e9a8b87b3213db0a14fbe7148edcd5365 /qtinterface/Makefile.am
parentce4313a6257fee35d97e07d22956f42916d4905c (diff)
downloadtqtinterface-5e266f8f85ead4c33f7a9d227a82b0461df7e09a.tar.gz
tqtinterface-5e266f8f85ead4c33f7a9d227a82b0461df7e09a.zip
Significant upgrades to the TQT system; kdelibs and kdebase now build and run correctly through TQT and Qt3
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/dependencies/tqtinterface@1152745 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'qtinterface/Makefile.am')
-rw-r--r--qtinterface/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/qtinterface/Makefile.am b/qtinterface/Makefile.am
index 43c1ff2..97841eb 100644
--- a/qtinterface/Makefile.am
+++ b/qtinterface/Makefile.am
@@ -25,7 +25,7 @@ KDE_OPTIONS = qtonly
INCLUDES = $(all_includes)
-bin_PROGRAMS =
+bin_PROGRAMS =
check_PROGRAMS =
lib_LTLIBRARIES = libtqt.la
@@ -131,3 +131,12 @@ METASOURCES = AUTO
DOXYGEN_REFERENCES = tqt
DOXYGEN_EXCLUDE = KDE-ICE
include ../admin/Doxyfile.am
+
+install-exec-local:
+ test -z "$(bindir)" || $(MKDIR_P) "$(DESTDIR)$(bindir)"
+ cp -Rp "$(srcdir)/tqt-replace" "$(DESTDIR)$(bindir)/"
+ cp -Rp "$(srcdir)/moc-tqt" "$(DESTDIR)$(bindir)/"
+ cp -Rp "$(srcdir)/mcopidl-tqt" "$(DESTDIR)$(bindir)/"
+ cp -Rp "$(srcdir)/dcopidl-tqt" "$(DESTDIR)$(bindir)/"
+ cp -Rp "$(srcdir)/dcopidlng-tqt" "$(DESTDIR)$(bindir)/"
+ cp -Rp "$(srcdir)/dcopidl2cpp-tqt" "$(DESTDIR)$(bindir)/" \ No newline at end of file