summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
new file mode 100644
index 0000000..931162a
--- /dev/null
+++ b/client/Makefile.am
@@ -0,0 +1,23 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = $(all_includes) -I$(kde_includes)/kwin
+
+kwindir = $(kde_datadir)/kwin/
+kwin_DATA = deKorator.desktop
+
+noinst_HEADERS = deKoratorclient.h shadow.h
+
+kde_module_LTLIBRARIES = kwin3_deKorator.la
+kwin3_deKorator_la_SOURCES = deKoratorclient.cc shadow.cpp
+kwin3_deKorator_la_LIBADD = $(kde_libraries)/libkdecorations.la
+kwin3_deKorator_la_LDFLAGS = -module $(all_libraries) $(KDE_PLUGIN) -lkdecore
+kwin3_deKorator_la_METASOURCES = AUTO
+
+DISTCLEANFILES = $(kwin3_deKorator_la_METASOURCES)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kwin_deKorator.po