summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2024-10-03 20:50:43 +0300
committerMavridis Philippe <[email protected]>2024-10-03 20:50:43 +0300
commitd7d77db04372685ebb6e7acaf9185566b13cbf1b (patch)
treee697db3842a38b0e8bf70647300a643735abaec2 /CMakeLists.txt
parent0c35ccad36b9f8b8763787c48138710fdf539977 (diff)
downloadtwin-style-mallory-d7d77db04372685ebb6e7acaf9185566b13cbf1b.tar.gz
twin-style-mallory-d7d77db04372685ebb6e7acaf9185566b13cbf1b.zip
Port to CMake, drop Autotools
Signed-off-by: Mavridis Philippe <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..80bf654
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,47 @@
+################################################################################
+# twin-style-mallory #
+# ------------------ #
+# This file is licensed under the terms of GNU GPL v3 or later. #
+# Improvements and feedback are welcome. #
+################################################################################
+
+project(twin-style-mallory)
+
+### Includes ###################################################################
+include(FindPkgConfig)
+include(CheckFunctionExists)
+include(CheckSymbolExists)
+include(CheckIncludeFile)
+include(CheckLibraryExists)
+include(CheckCSourceCompiles)
+include(CheckCXXSourceCompiles)
+
+include(TDEMacros)
+include(TDESetupPaths)
+include(TDEVersion)
+
+### Basic project setup ########################################################
+cmake_minimum_required(VERSION ${TDE_CMAKE_MINIMUM_VERSION})
+tde_set_project_version()
+tde_setup_paths()
+
+### Options ####################################################################
+option(WITH_ALL_OPTIONS "Enable all optional support" OFF)
+option(WITH_GCC_VISIBILITY "Enable GCC visibility" ${WITH_ALL_OPTIONS})
+
+### Components #################################################################
+option(BUILD_ALL "Build all" ON)
+option(BUILD_COLORSCHEMES "Install colorschemes" ${BUILD_ALL})
+option(BUILD_TCC_MODULE "Build Control Centre module" ${BUILD_ALL})
+option(BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL})
+
+### Configuration ##############################################################
+include(ConfigureChecks.cmake)
+configure_file(config.h.cmake config.h @ONLY)
+
+### Subdirectories #############################################################
+add_subdirectory(malloryclient)
+tde_conditional_add_subdirectory(BUILD_COLORSCHEMES colorscheme)
+# tde_conditional_add_project_translations()
+
+# kate: indent-width 2; replace-tabs true; \ No newline at end of file