summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:10:00 +0900
committerMichele Calgaro <[email protected]>2024-03-17 11:19:26 +0900
commit0a6d1be49ac88a82ac5a0bbfbaeff366c8d2998d (patch)
treec19bb25b022431f1c563071c09ce0f2fff9b2016 /CMakeLists.txt
parenta71308e86c8cf4179b218a772a19e94553fa6aad (diff)
downloadyakuake-0a6d1be49ac88a82ac5a0bbfbaeff366c8d2998d.tar.gz
yakuake-0a6d1be49ac88a82ac5a0bbfbaeff366c8d2998d.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c31356..6a9a349 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -30,11 +34,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )