summaryrefslogtreecommitdiffstats
path: root/mcop_mt/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-12-27 12:33:55 +0900
committerMichele Calgaro <[email protected]>2024-12-27 20:39:23 +0900
commit45ff2423e03a3ed3c8855c7b599a664891623ba1 (patch)
tree125a2be62df1dfbda9e284b0d371a1fd363103bf /mcop_mt/CMakeLists.txt
parent493173b2a861800c6f2b9eb9e50c1d0dd2db8557 (diff)
downloadarts-45ff2423e03a3ed3c8855c7b599a664891623ba1.tar.gz
arts-45ff2423e03a3ed3c8855c7b599a664891623ba1.zip
Replace pthread and dl linking with cmake-based variables
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'mcop_mt/CMakeLists.txt')
-rw-r--r--mcop_mt/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/mcop_mt/CMakeLists.txt b/mcop_mt/CMakeLists.txt
index 832b6d8..8816447 100644
--- a/mcop_mt/CMakeLists.txt
+++ b/mcop_mt/CMakeLists.txt
@@ -24,6 +24,6 @@ include_directories(
tde_add_library( mcop_mt SHARED
SOURCES threads_posix.cpp
VERSION 1.0.0
- LINK artsflow-shared pthread
+ LINK artsflow-shared ${CMAKE_THREAD_LIBS_INIT}
DESTINATION ${LIB_INSTALL_DIR}
)