summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-08-27 16:26:49 +0200
committerMichele Calgaro <[email protected]>2020-08-29 15:34:39 +0900
commitd1571dea2aac285280c35383f79cda03cdcb913f (patch)
tree4fb2b0325739d4ea5021711661931e7e07c6097a /src/Makefile.am
parenta4e0262b214c035df0fa1808192e332806396265 (diff)
downloadkima-d1571dea2aac285280c35383f79cda03cdcb913f.tar.gz
kima-d1571dea2aac285280c35383f79cda03cdcb913f.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty file NEWS. Rework of the README file (splitted with the FAQ). Add FAQ file. Rework of the desktop file. Few cosmetics here and there. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit c4ba990dcc1531424959545520236b033847905b)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 0 insertions, 22 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index d6db9c8..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,22 +0,0 @@
-INCLUDES = -I$(top_srcdir)/src/cpufreqd -I$(top_srcdir)/src/sources \
- $(all_includes)
-METASOURCES = AUTO
-
-kde_module_LTLIBRARIES = libkima.la
-
-libkima_la_SOURCES = kima.cpp flowlayout.cpp sourcelistitem.cpp prefs.ui
-libkima_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
-libkima_la_LIBADD = $(top_builddir)/src/cpufreqd/libcpufreqd.la \
- $(top_builddir)/src/sources/libsources.la $(LIB_TDEUI)
-
-kima_DATA = kima.desktop
-kimadir = $(kde_datadir)/kicker/applets
-
-KDE_ICON = hwinfo
-EXTRA_DIST = $(kima_DATA)
-
-messages: rc.cpp
- $(XGETTEXT) *.cpp */*.cpp -o $(podir)/kima.pot
-noinst_HEADERS = kima.h flowlayout.h sourcelistitem.h
-
-SUBDIRS = cpufreqd sources